BBB Locks up when dragging file in File Manager (Bug #49)


Added by Louis McCarthy over 3 years ago. Updated over 3 years ago.


Status:Resolved Start date:01/16/2014
Priority:High Due date:
Assignee:Robert Nelson % Done:

50%

Category:-
Target version:-

Description

Using stock eMMC image, external power supply.

Open File Manager. Left-Click and hold on any file. Move it a fraction of an icon distance. BBB locks up hard.


History

Updated by Robert Nelson over 3 years ago

Yeah a few gtk apps do this, even some of the applications on the original Angstrom image...

sudo apt-get install gpicview

lxde -> Accessories -> "Image Viewer" - "Open File" -> boot -> Docs -> images -> beagle.png -> Open -> HARDLOCK...

In our weekly call today, the guys with TI where going to look into it, as the board locks HARD... (no debug/etc..)

  • Assignee set to Robert Nelson
  • Status changed from New to In Progress

Updated by Robert Nelson over 3 years ago

Adding some more notes..

affected kernels:
v3.8.x
v3.12.x
v3.13-rcX

Tried updating modesetting driver..

http://rcn-ee.net/pkgs/xserver-xorg-video-modesetting/xserver-xorg-video-modesetting_0.8.1/xserver-xorg-video-modesetting_0.8.1-1_armhf.deb

Tried enabling kernel debugging/hard lock detection.. No go..

Updated by Louis McCarthy over 3 years ago

I was able to reproduce it on a BBW with an LCD3:A1 (stock 1/10/2014 image)

Nothing was reported to the debug console.

Updated by Robert Nelson over 3 years ago

Just finished testing next... So v3.14-rc0 will have the issue too..

https://github.com/RobertCNelson/linux-next

For some reason my version of ti's 3.12 kernel broke, so I haven't been able to test that yet..

Updated by Robert Nelson over 3 years ago

Cody Lacey found one fix for this:

https://github.com/RobertCNelson/omap-image-builder/commit/3faedf9308b4adcdac6a747aadff44ede33cb59b

It can still lockup with some apps, but it's less..

Updated by Robert Nelson over 3 years ago

With the workarounds, the dragging is fixed..

  • % Done changed from 0 to 50

Updated by Bill Traynor over 3 years ago

Is this still a valid bug?

Updated by Robert Nelson over 3 years ago

This "should" be fixed by using the "fbdev" driver vs "modesetting" in xorg.conf, this was made default in the offical "2014-04-23" image.

  • Status changed from In Progress to Resolved

Also available in: Atom PDF