Cloud9 IDE preview functionality is broken (Bug #59)


Added by Jason Kridner over 3 years ago. Updated over 3 years ago.


Status:Closed Start date:03/06/2014
Priority:Normal Due date:
Assignee:Jason Kridner % Done:

0%

Category:-
Target version:-

Description

Trying to preview an HTML file from the Cloud9 IDE such as:

http://beaglebone.local:3000/preview/extras/bacon_cape/demo_flot.html

gives the error:

Server Error !!
404 - standalone Cannot GET /:systemd/vfs/1/preview/extras/bacon_cape/demo_flot.html


History

Updated by Robert Nelson over 3 years ago

Notice this too in the log window, might just create a symlink on httpd.

Started Apache httpd, serving localhost/extras/bacon_cape/demo_flot.html.
sh: 2: httpd: not found

Updated by Jason Kridner over 3 years ago

I haven't seen the invocation of Apache. I'll try to look for that.

Starting to debug, I see it tries to open 'localhost:systemd' rather than 'localhost:3000' in /opt/cloud9/plugins/c9.preview/preview.handler.js.

This port redefinition is starting to cause some headaches. I might removing all of the environment and config file changes and simply replace the port definition in the call to open the socket for the main server, since that line needed to be patched for systemd anyway.

Updated by Jason Kridner over 3 years ago

I confirmed this worked to enable preview. I need to look at how you build this up with the script so I can send you the changes.

I still haven't seen the Apache/httpd issue.

Updated by Jason Kridner over 3 years ago

Robert, the reason you got THAT error was you attempted to 'run' rather than 'preview'. That seems to be a somewhat related issue that also might be worth fixing.

Updated by Bill Traynor over 3 years ago

Is this still a valid open bug?

Updated by Robert Nelson over 3 years ago

I believe Jason resolved this in the release image?

  • Status changed from New to In Progress

Updated by Jason Kridner over 3 years ago

Yes. How do I close the bug?

Updated by Robert Nelson over 3 years ago

Update -> Status -> closed ;)

  • Status changed from In Progress to Closed

Also available in: Atom PDF